It was possible to execute JavaScript code in the Microblog search.

Advisory Release Date



Microblogging for Confluence

Linchpin Intranet Suite

Affected Versions

Linchpin Intranet Suite 5.3.2 and all prior versions

Microblogging for Confluence 6.2.2 and all prior versions

Fixed Versions

Linchpin Intranet Suite 5.3.3

Microblogging for Confluence 6.2.3


The issues were discovered by Jafar Abo Nada via the Atlassian bug bounty program. The researcher could identify that an attacker could potentially inject executable Javascript code within the Microblog search, that was then reflected to the viewing user.

Affected are the apps "Microblogging for Confluence" up to and including version 6.2.3 and "Linchpin Intranet Suite" up to and including version 5.3.2.


The vulnerability is rated as 8.7 according to CVSS. The score is calculated as CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N.


For Microblogging for Confluence customers: Update to Microblogging for Confluence version 6.2.3 or later.

For Linchpin Suite customers: Update to Linchpin Suite 5.3.3 or later.

Should you be unable to update the Linchpin Intranet Suite to one of the listed versions, please reach out to our support team at

  • No labels

This content was last updated on 09/14/2022.

This content hasn't been updated in a while. That doesn't have to be a problem. Some of our pages live for years without becoming obsolete.

Old content can be incorrect, misleading or outdated. Please get in contact with us via a form on this page, our live chat or via email with if you are in doubt, have a question, suggestion, or want changes from us.