Problem
We received several reports describing the following situation:
After an update of Confluence, a Linchpin app or a third party app has been performed, some areas of Confluence were not accessible or page elements, widgets and similar functions of Linchpin were not all working as expected, usually displaying text instead of the visual content.
Diagnosis
The behavior has been reported to occur on a variety of versions of both Confluence and the Linchpin apps. Symptoms can look like one or more of the following:
- Inaccessible login screen, showing only a error message containing "Unable to find resource '/login/$confluenceVersionLogin.getVmdFolderForConfluenceVersion()/login.vmd'" in the server logfiles
- Broken theme, so that elements are not styled properly
- One or more configuration items missing from the Linchpin Theme configuration section
- Missing footer, showing only the text $themeFooter.getRendered()
- Missing Linchpin sidebar or Linchpin sidebar components, either not displaying or displaying one line of text similar to the above (depends on which module is missing)
- Macros randomly getting disabled and thus becoming unavailable
- "$linchpinTheme.get("intranetName", $ltpCtx) is shown instead of the page header
Please refer to the Workaround section below for more information on how to check if this is potentially the case.
Cause
We were able to track the root cause down to the following Confluence bug reported to Atlassian: CONFSERVER-22390 Plugin's velocity module is disabled by Confluence.
Atlassian have fixed the issue and provided patches for the Long Term Support line Confluence 7.4 as well as for most newer versions (please refer to the ticket for the detailed list).
After updating Confluence to one of the versions listed, we were no longer able to observe disabled modules in the Linchpin apps. In particular, if you are using the 7.4 Long Term Support line, we recommend updating to Confluence 7.4.7 or newer.
Workaround
If Confluence or the Linchpin apps shows one or more of the behaviors listed above or similar issues, please check if all required modules of the Linchpin apps are enabled in the UPM:
- Open the Manage apps section of the Confluence Administration.
- Locate the app Linchpin Theme and expand it.
- In the bottom right section of the app details, verify that all modules which your site needs to work are indeed enabled.
(Depending on your system configuration and other installed apps, it's possible that some modules are disabled because they are indeed not needed.)
These steps should be performed at least for these apps:
- Linchpin Theme
- Linchpin Theme - Confluence Default Theme
- Linchpin Theme - Custom Landing Spaces
- Linchpin Theme - Login
- Linchpin Theme - Navigation Menus
- Linchpin Theme - Sidebar
- Linchpin Theme - Space Directory
When in doubt whether some of the modules that you see as Disabled are either expected to be in this state, or deliberately disabled, please reach out to our app support with a screenshot of the module list in question and we're happy to help!
Resolution
Update Confluence to one of the versions listed as fix versions in CONFSERVER-22390.
- Linchpin Theme is part of the Linchpin Intranet Suite and Linchpin Essentials